summaryrefslogtreecommitdiff
path: root/x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild')
-rw-r--r--x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild b/x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild
new file mode 100644
index 0000000..3dd7715
--- /dev/null
+++ b/x11-themes/numix-frost/numix-frost-3.6.6-r2.ebuild
@@ -0,0 +1,40 @@
+EAPI=6
+
+DESCRIPTION="Numix is a modern flat theme with a combination of light and dark elements."
+HOMEPAGE="https://github.com/Antergos/Numix-Frost"
+
+# Note: We need few more commits to fix some build problems
+# But those contains binary files patches that can't portage handle so we just
+# specify exact hash instead. When new version is release, return to versions.
+HASH="e9d250792bced3b64c50e72c4f3404a2c020dc3e"
+SRC_URI="https://github.com/Antergos/Numix-Frost/archive/${HASH}.tar.gz -> ${PN}.tar.gz"
+S="${WORKDIR}/numix-frost"
+
+KEYWORDS="amd64"
+LICENSE="GPL-3.0+"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ruby/sass
+ dev-ruby/bundler"
+RDEPEND="
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ x11-themes/gtk-engines-murrine"
+
+# Note: This is needed because utils.sh expect repository name to be numix-frost
+src_unpack() {
+ unpack "${A}"
+ mv "${WORKDIR}"/Numix-Frost-${HASH} "$S"
+}
+
+src_compile() {
+ emake -j1
+}
+
+# Jep and makefiles doesn't like to be run in paralel (you have to love it)
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}