summaryrefslogtreecommitdiff
path: root/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild')
-rw-r--r--x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild b/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
new file mode 100644
index 0000000..0625be0
--- /dev/null
+++ b/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
@@ -0,0 +1,35 @@
+EAPI=6
+
+DESCRIPTION="Background pictures from lnxpcs and relevant scripts"
+HOMEPAGE="https://gitlab.com/jstpcs/lnxpcs"
+
+HASH="99cf0bdafe6d9c6e0554c422eddc3f7b7adf25c8"
+SRC_URI="https://gitlab.com/jstpcs/lnxpcs/-/archive/master/lnxpcs-${HASH}.tar.gz -> ${PN}.tar.gz"
+S="${WORKDIR}/lnxpcs-master-${HASH}"
+
+KEYWORDS="amd64"
+LICENSE="GPL-3.0+"
+SLOT="0"
+IUSE=""
+
+DEPENDS="media-gfx/imagemagick[png]"
+RDEPEND="
+ x11-misc/i3lock
+ media-gfx/feh[xinerama]"
+
+WALLPAPERS="bash cron gcc gnu gnu-linux iptables kernel kill python root su sudo vim"
+
+src_compile() {
+ for IMG in $WALLPAPERS; do
+ ./makemywall 1920 1080 "cards/black/$IMG-card-black.png"
+ done
+}
+
+src_install() {
+ insinto "/usr/share/backgrounds"
+ for IMG in $WALLPAPERS; do
+ doins "$IMG-card-black-1920x1080.png"
+ done
+ dobin "${FILESDIR}/i3background"
+ dobin "${FILESDIR}/i3lock-lnxpcs"
+}