summaryrefslogtreecommitdiff
path: root/x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild')
-rw-r--r--x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild b/x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild
new file mode 100644
index 0000000..405e187
--- /dev/null
+++ b/x11-themes/background-lnxpcs/background-lnxpcs-0.1.1.ebuild
@@ -0,0 +1,33 @@
+EAPI=6
+
+DESCRIPTION="Background pictures from lnxpcs and relevant scripts"
+HOMEPAGE="https://gitlab.com/jstpcs/lnxpcs"
+
+HASH="99cf0bdafe6d9c6e0554c422eddc3f7b7adf25c8"
+SRC_URI="https://gitlab.com/jstpcs/lnxpcs/-/archive/master/lnxpcs-${HASH}.tar.gz -> ${PN}.tar.gz"
+S="${WORKDIR}/lnxpcs-master-${HASH}"
+
+KEYWORDS="amd64"
+LICENSE="GPL-3.0+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-misc/i3lock
+ media-gfx/feh[xinerama]"
+
+WALLPAPERS="cron gcc gnu iptables kernel python root sudo vim"
+
+src_compile() {
+ # Nothing to compile
+ true
+}
+
+src_install() {
+ insinto "/usr/share/backgrounds"
+ for IMG in $WALLPAPERS; do
+ doins "walls/solarized-dark/solarized-wallpaper-$IMG.png"
+ done
+ dobin "${FILESDIR}/i3background"
+ dobin "${FILESDIR}/i3lock-lnxpcs"
+}