summaryrefslogtreecommitdiff
path: root/x11-misc/florence/florence-0.6.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/florence/florence-0.6.3-r1.ebuild')
-rw-r--r--x11-misc/florence/florence-0.6.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/florence/florence-0.6.3-r1.ebuild b/x11-misc/florence/florence-0.6.3-r1.ebuild
new file mode 100644
index 0000000..588e2e0
--- /dev/null
+++ b/x11-misc/florence/florence-0.6.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Florence is an extensible scalable virtual keyboard for X11"
+HOMEPAGE="http://florence.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+at-spi +libnotify +xtst docs"
+
+DEPEND="
+ >=x11-libs/gtk+-3.0
+ dev-libs/libxml2
+ gnome-base/librsvg
+ sys-devel/gettext
+ dev-util/intltool
+ media-libs/gstreamer
+ at-spi? ( app-accessibility/at-spi2-core )
+ libnotify? ( x11-libs/libnotify )
+ xtst? ( x11-libs/libXtst )
+ docs? ( app-text/gnome-doc-utils )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_with at-spi) \
+ $(use_with libnotify) \
+ $(use_with xtst) \
+ $(use_with docs)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}