summaryrefslogtreecommitdiff
path: root/sys-kernel/linux/linux-4.10.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux/linux-4.10.13.ebuild')
-rw-r--r--sys-kernel/linux/linux-4.10.13.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-kernel/linux/linux-4.10.13.ebuild b/sys-kernel/linux/linux-4.10.13.ebuild
index bc0ebb9..ad38a3f 100644
--- a/sys-kernel/linux/linux-4.10.13.ebuild
+++ b/sys-kernel/linux/linux-4.10.13.ebuild
@@ -33,10 +33,10 @@ src_install() {
src_postinst() {
# Add label to syslinux config
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND root=/dev/sda2 rootflags=subvol=@gentoo\n\tINITRD ../initramfs-gentoo\n" /boot/syslinux/syslinux.cnf
+ sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND root=/dev/sda2 rootflags=subvol=@gentoo\n\tINITRD ../initramfs-gentoo\n" /boot/syslinux/syslinux.cfg || eerror "Adding label to syslinux configuration failed!"
}
src_prerm() {
# Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cnf
+ sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
}