summaryrefslogtreecommitdiff
path: root/sys-kernel/cgroup-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/cgroup-systemd')
-rw-r--r--sys-kernel/cgroup-systemd/cgroup-systemd-1.0.ebuild13
-rw-r--r--sys-kernel/cgroup-systemd/files/cgroup-systemd12
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-kernel/cgroup-systemd/cgroup-systemd-1.0.ebuild b/sys-kernel/cgroup-systemd/cgroup-systemd-1.0.ebuild
new file mode 100644
index 0000000..1a56baf
--- /dev/null
+++ b/sys-kernel/cgroup-systemd/cgroup-systemd-1.0.ebuild
@@ -0,0 +1,13 @@
+EAPI=7
+
+DESCRIPTION="Init script to mount systemd cgroup automatically"
+HOMEPAGE="http://git.cynerd.cz/gentoo-personal-overlay/"
+S="${WORKDIR}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_install() {
+ doinitd "${FILESDIR}/cgroup-systemd"
+}
diff --git a/sys-kernel/cgroup-systemd/files/cgroup-systemd b/sys-kernel/cgroup-systemd/files/cgroup-systemd
new file mode 100644
index 0000000..faccf09
--- /dev/null
+++ b/sys-kernel/cgroup-systemd/files/cgroup-systemd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+
+description="Mounts systemd's cgroup."
+
+depend() {
+ need root
+}
+
+start() {
+ mkdir -p /sys/fs/cgroup/systemd
+ mount -t cgroup -o none,name=systemd systemd /sys/fs/cgroup/systemd
+}