summaryrefslogtreecommitdiff
path: root/sys-devel/ct-ng/ct-ng-220209.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/ct-ng/ct-ng-220209.ebuild')
-rw-r--r--sys-devel/ct-ng/ct-ng-220209.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ct-ng-220209.ebuild b/sys-devel/ct-ng/ct-ng-220209.ebuild
new file mode 100644
index 0000000..b211c8f
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-220209.ebuild
@@ -0,0 +1,29 @@
+EAPI="7"
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="https://crosstool-ng.github.io/"
+HASH="ba680a3e5b8c62a7c1554e71f6d09903dac95a2f"
+SRC_URI="https://github.com/crosstool-ng/crosstool-ng/archive/${HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/crosstool-ng-${HASH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_configure() {
+ ./bootstrap
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}