summaryrefslogtreecommitdiff
path: root/net-im/ferdi/ferdi-5.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ferdi/ferdi-5.8.0.ebuild')
-rw-r--r--net-im/ferdi/ferdi-5.8.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-im/ferdi/ferdi-5.8.0.ebuild b/net-im/ferdi/ferdi-5.8.0.ebuild
new file mode 100644
index 0000000..a3e30e7
--- /dev/null
+++ b/net-im/ferdi/ferdi-5.8.0.ebuild
@@ -0,0 +1,20 @@
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Messaging app that combines common web applications into one"
+HOMEPAGE="https://getferdi.com/"
+SRC_URI="https://github.com/getferdi/ferdi/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_install() {
+ dodir /opt
+ cp -R "${S}/${P}/" "${D}/opt/ferdi/" || die "Install failed!"
+ dodir /usr/bin
+ ln -s /opt/ferdi/ferdi "${D}/usr/bin/ferdi"
+ make_desktop_entry ferdi Ferdi
+}