summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
new file mode 100644
index 0000000..a1debc5
--- /dev/null
+++ b/dev-vcs/python-gitlab/Manifest
@@ -0,0 +1 @@
+DIST python-gitlab-2.7.1.tar.gz 170616 BLAKE2B f04fc3d6d892a2312012f7029e98b529ec404a5072e1ee25f072e39f2af9bcfde8518a7952ba0bfcba2bf031fa977bfee017fb613b5e45c1b6f213841cdce36e SHA512 31afa9e69e5cdb9de7638aae4e5fd87687ee89929acc97fd78690c860db8be99e65b39a7409b0b91c819f3de3d720dd0e670156f471043cc51396cbf2d820308
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
new file mode 100644
index 0000000..615fc53
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}