summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cheroot/Manifest1
-rw-r--r--dev-python/cheroot/cheroot-6.5.6.ebuild53
-rw-r--r--dev-python/cheroot/files/6.5.4-fix-requirements.patch10
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
new file mode 100644
index 0000000..a36512b
--- /dev/null
+++ b/dev-python/cheroot/Manifest
@@ -0,0 +1 @@
+DIST cheroot-6.5.6.tar.gz 84633 BLAKE2B 3e73eaf1269bd698a307363897e0232a7b10876613e953ad5afe2b260762235ad9a389e49c2d835188b8ed0da296a0023f5e9de7460f18da696fcf87ffb9d3b1 SHA512 6796940e9a3f09fcdbf8c75a820222619dd7388012f294396e425d7d535b3a1a8962e9c206d2951b58c8ec04d921b57e54fca70e8775adf9ec219834cada0e8c
diff --git a/dev-python/cheroot/cheroot-6.5.6.ebuild b/dev-python/cheroot/cheroot-6.5.6.ebuild
new file mode 100644
index 0000000..91d2b93
--- /dev/null
+++ b/dev-python/cheroot/cheroot-6.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="https://cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+# Unit tests are temporarily disabled for this version, see below for
+# what needs to be done.
+# IUSE="test"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]"
+
+ # Add the following for unit tests, some packages listed will need
+ # to be added and keyworded appropriately.
+# test? (
+# dev-python/ddt[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-sugar[${PYTHON_USEDEP}]
+# dev-python/pytest-testmon[${PYTHON_USEDEP}]
+# dev-python/pytest-watch[${PYTHON_USEDEP}]
+# dev-python/pytest-xdist[${PYTHON_USEDEP}]
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/codecov[${PYTHON_USEDEP}]
+# dev-python/pytest-cov[${PYTHON_USEDEP}]
+# dev-python/trustme[${PYTHON_USEDEP}]
+# dev-python/pyopenssl[${PYTHON_USEDEP}]
+# dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+# )"
+
+PATCHES=(
+ # https://github.com/CherryPy/cheroot/issues/181
+ "${FILESDIR}"/6.5.4-fix-requirements.patch
+)
+
+# python_test() {
+# py.test -v || die "tests failed under ${EPYTHON}"
+# }
diff --git a/dev-python/cheroot/files/6.5.4-fix-requirements.patch b/dev-python/cheroot/files/6.5.4-fix-requirements.patch
new file mode 100644
index 0000000..a5a4937
--- /dev/null
+++ b/dev-python/cheroot/files/6.5.4-fix-requirements.patch
@@ -0,0 +1,10 @@
+--- a/setup.cfg 2019-03-09 17:14:40.127863655 -0600
++++ b/setup.cfg 2019-03-09 17:15:22.135345396 -0600
+@@ -57,7 +57,6 @@
+ setuptools_scm>=1.15.0
+ setuptools_scm_git_archive>=1.0
+ install_requires =
+- backports.functools_lru_cache
+ six>=1.11.0
+ more_itertools>=2.6
+