summaryrefslogtreecommitdiff
path: root/dev-python/schema
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/schema')
-rw-r--r--dev-python/schema/Manifest1
-rw-r--r--dev-python/schema/schema-0.6.8.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
new file mode 100644
index 0000000..0cba773
--- /dev/null
+++ b/dev-python/schema/Manifest
@@ -0,0 +1 @@
+DIST schema-0.6.8.tar.gz 18970 BLAKE2B 6167a6f84c783cc7a18a0343f009bcf790bafe381bb743acddb374430a1a60d0cbab81718faa866bfdb2f76bf0552948a71d7adf78070340ed12a5f1719a4014 SHA512 2c987da4bfff42b42b40b221707019e1cb131c1516ec29a6d564a84dd78e3ccf7f52e47c969812564df6db7e9a7a689cefa123d573cefc8f11d444c8ff5e3647
diff --git a/dev-python/schema/schema-0.6.8.ebuild b/dev-python/schema/schema-0.6.8.ebuild
new file mode 100644
index 0000000..a478507
--- /dev/null
+++ b/dev-python/schema/schema-0.6.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"