summaryrefslogtreecommitdiff
path: root/dev-python/pyls
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyls')
-rw-r--r--dev-python/pyls/Manifest1
-rw-r--r--dev-python/pyls/pyls-0.21.2-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyls/Manifest b/dev-python/pyls/Manifest
new file mode 100644
index 0000000..f867d22
--- /dev/null
+++ b/dev-python/pyls/Manifest
@@ -0,0 +1 @@
+DIST pyls-0.21.2.tar.gz 439047 BLAKE2B 27a3ad29c95424717223ac9a1edc4d58b3d5fd3f3caabc0e819a20192f017cff6943e66c1947755f1ed1e1f771e20ac179f7c81091ec24f9ef58b7850aa1d45b SHA512 f66cdd63cfbc3880d4ed0b066e50f09c5f042ea366be255ee7aaf5b5e1df0838ec9dbd6be3d5cd642c10540ea6f02d8487ed3d389fff53c9fb19e0cb5cbdfa28
diff --git a/dev-python/pyls/pyls-0.21.2-r1.ebuild b/dev-python/pyls/pyls-0.21.2-r1.ebuild
new file mode 100644
index 0000000..9d45ec4
--- /dev/null
+++ b/dev-python/pyls/pyls-0.21.2-r1.ebuild
@@ -0,0 +1,25 @@
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit python-single-r1
+
+DESCRIPTION="Python Language Server"
+HOMEPAGE="https://github.com/palantir/python-language-server"
+SRC_URI="https://github.com/palantir/python-language-server/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-language-server-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/future-0.14.0
+ >=dev-python/jedi-0.12
+ dev-python/python-jsonrpc-server
+ dev-python/pluggy"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}