summaryrefslogtreecommitdiff
path: root/dev-python/pyls/pyls-0.21.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyls/pyls-0.21.2-r1.ebuild')
-rw-r--r--dev-python/pyls/pyls-0.21.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyls/pyls-0.21.2-r1.ebuild b/dev-python/pyls/pyls-0.21.2-r1.ebuild
new file mode 100644
index 0000000..9d45ec4
--- /dev/null
+++ b/dev-python/pyls/pyls-0.21.2-r1.ebuild
@@ -0,0 +1,25 @@
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit python-single-r1
+
+DESCRIPTION="Python Language Server"
+HOMEPAGE="https://github.com/palantir/python-language-server"
+SRC_URI="https://github.com/palantir/python-language-server/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-language-server-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/future-0.14.0
+ >=dev-python/jedi-0.12
+ dev-python/python-jsonrpc-server
+ dev-python/pluggy"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}