summaryrefslogtreecommitdiff
path: root/dev-python/pyls/pyls-0.21.2-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-11 15:34:12 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-11 15:34:12 +0200
commit489ff5d0064d3eb6bf5dc6889e634e577efde672 (patch)
tree4f92eef733322f6bf86509c7d999f168688a87dd /dev-python/pyls/pyls-0.21.2-r1.ebuild
parentf3f0eceaeccd514cb4462874edaee7c5ec80a677 (diff)
downloadgentoo-personal-overlay-489ff5d0064d3eb6bf5dc6889e634e577efde672.tar.gz
gentoo-personal-overlay-489ff5d0064d3eb6bf5dc6889e634e577efde672.tar.bz2
gentoo-personal-overlay-489ff5d0064d3eb6bf5dc6889e634e577efde672.zip
Add package for pyls and its dependency
Diffstat (limited to 'dev-python/pyls/pyls-0.21.2-r1.ebuild')
-rw-r--r--dev-python/pyls/pyls-0.21.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyls/pyls-0.21.2-r1.ebuild b/dev-python/pyls/pyls-0.21.2-r1.ebuild
new file mode 100644
index 0000000..9d45ec4
--- /dev/null
+++ b/dev-python/pyls/pyls-0.21.2-r1.ebuild
@@ -0,0 +1,25 @@
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit python-single-r1
+
+DESCRIPTION="Python Language Server"
+HOMEPAGE="https://github.com/palantir/python-language-server"
+SRC_URI="https://github.com/palantir/python-language-server/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-language-server-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/future-0.14.0
+ >=dev-python/jedi-0.12
+ dev-python/python-jsonrpc-server
+ dev-python/pluggy"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}