summaryrefslogtreecommitdiff
path: root/dev-lua/lua-compat
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-compat')
-rw-r--r--dev-lua/lua-compat/Manifest1
-rw-r--r--dev-lua/lua-compat/lua-compat-0.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lua/lua-compat/Manifest b/dev-lua/lua-compat/Manifest
new file mode 100644
index 0000000..1b97b26
--- /dev/null
+++ b/dev-lua/lua-compat/Manifest
@@ -0,0 +1 @@
+DIST lua-compat-0.3.tar.gz 22407 BLAKE2B f8fa3aba2aab85b701c688a771e59b664c6541d1048c8e9d9a846e4458fffff451fba40f72f5e6d4310f533d860269e07f5135d3f44aa1b61de9755df8c2834a SHA512 b6b70162d5b25e3cc646613ee62a8f136903b4e0ae749285105429cce0e5d3eebc3295aa98749239651dd67d5ee55199172267cefb1588969093770a7e82ac96
diff --git a/dev-lua/lua-compat/lua-compat-0.3.ebuild b/dev-lua/lua-compat/lua-compat-0.3.ebuild
new file mode 100644
index 0000000..3312df8
--- /dev/null
+++ b/dev-lua/lua-compat/lua-compat-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua-5.2-style APIs for Lua 5.1"
+HOMEPAGE="https://github.com/keplerproject/lua-compat-5.2"
+SRC_URI="https://github.com/keplerproject/lua-compat-5.2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bit32 +compat52"
+
+RDEPEND="dev-lang/lua:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lua-compat-5.2-0.3"
+
+src_compile() {
+ if use bit32; then
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o bit32.so lbitlib.c c-api/compat-5.2.c || die
+ fi
+}
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/term
+ if use bit32; then
+ doins bit32.so
+ fi
+ if use compat52; then
+ doins compat52.lua
+ newins compat52/strict.lua compat52.strict.lua
+ newins compat52/mstrict.lua compat52.mstrict.lua
+ fi
+}
+