summaryrefslogtreecommitdiff
path: root/dev-libs/logc/logc-0.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/logc/logc-0.1.3.ebuild')
-rw-r--r--dev-libs/logc/logc-0.1.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/logc/logc-0.1.3.ebuild b/dev-libs/logc/logc-0.1.3.ebuild
new file mode 100644
index 0000000..da1039b
--- /dev/null
+++ b/dev-libs/logc/logc-0.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Logging for C"
+HASH="2e403f55c0e41bc7781d2e62d03966b5e99fdb2a"
+HOMEPAGE="https://gitlab.nic.cz/turris/logc"
+SRC_URI="https://gitlab.nic.cz/turris/logc/-/archive/$HASH/logc-$HASH.tar.gz"
+S="${WORKDIR}/logc-$HASH"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ ./bootstrap
+ econf \
+ --disable-tests \
+ --disable-valgrind \
+ --disable-linters
+}