summaryrefslogtreecommitdiff
path: root/dev-libs/logc/logc-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/logc/logc-0.1.1.ebuild')
-rw-r--r--dev-libs/logc/logc-0.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/logc/logc-0.1.1.ebuild b/dev-libs/logc/logc-0.1.1.ebuild
new file mode 100644
index 0000000..b3ecaa1
--- /dev/null
+++ b/dev-libs/logc/logc-0.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Logging for C"
+HASH="1b1069a072974479068e808aae516cbe851d0cbf"
+HOMEPAGE="https://gitlab.nic.cz/turris/logc"
+SRC_URI="https://gitlab.nic.cz/turris/logc/-/archive/$HASH/logc-$HASH.tar.gz"
+S="${WORKDIR}/logc-$HASH"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ ./bootstrap
+ econf \
+ --disable-tests \
+ --disable-valgrind \
+ --disable-linters
+}