summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/devel/packages3
-rw-r--r--sci-electronics/qucs/Manifest1
-rw-r--r--sci-electronics/qucs/qucs-0.0.19.ebuild66
3 files changed, 70 insertions, 0 deletions
diff --git a/profiles/devel/packages b/profiles/devel/packages
index aa9f2ac..c1b410b 100644
--- a/profiles/devel/packages
+++ b/profiles/devel/packages
@@ -19,6 +19,9 @@ app-emulation/lxc
# GHDL
#sci-electronics/ghdl
+# Electronics
+sci-electronics/qucs
+
# Rust
dev-lang/rust
diff --git a/sci-electronics/qucs/Manifest b/sci-electronics/qucs/Manifest
new file mode 100644
index 0000000..769f200
--- /dev/null
+++ b/sci-electronics/qucs/Manifest
@@ -0,0 +1 @@
+DIST qucs-0.0.19.tar.gz 20594557 SHA256 45c6434fde24c533e63550675ac21cdbd3cc6cbba29b82a1dc3f36e7dd4b3b3e SHA512 0ce68bc84a14ba0515bee4acb3f6e77f9637de817e3a75cba20ca88f093d0e06b9ad229df09e7d0953ceb5b0902dc4dd902a6b5bf7fee1e4a056b55fc7bb3867 WHIRLPOOL 0b67370831bca376c005256121a0d1480fb0e0f9ebdd3eee5be7f3cb609fdbd3eab457a2c65a9f410f54f0556e490c2e0c00358c19b29e1c31f32d1248b90517
diff --git a/sci-electronics/qucs/qucs-0.0.19.ebuild b/sci-electronics/qucs/qucs-0.0.19.ebuild
new file mode 100644
index 0000000..1e5110b
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.19.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Quite Universal Circuit Simulator in Qt4"
+HOMEPAGE="http://qucs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="dev-qt/qtcore:4[qt3support]
+ dev-qt/qtgui:4[qt3support]
+ dev-qt/qtscript:4
+ dev-qt/qtsvg:4
+ dev-qt/qt3support:4
+ x11-libs/libX11:0="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # oh my, they strip -g out of C*FLAGS and force -s into LDFLAGS
+ # note: edit .ac first, then generated files, so that the latter
+ # have newer timestamp and not trigger regen
+ sed -i \
+ -e 's/C.*FLAGS.*sed.*-g.*$/:/' \
+ -e 's/C.*FLAGS.*-O0.*$/:/' \
+ -e 's/LDFLAGS.*-s.*$/:/' \
+ configure.ac asco/configure.ac qucs-core/configure.ac \
+ configure asco/configure qucs-core/configure \
+ || die "C*FLAGS and LDFLAGS sanitization sed failed"
+}
+
+src_configure() {
+ local myconf=(
+ # enables asserts and debug codepaths
+ $(use_enable debug)
+
+ # avoid automagic dep
+ # TODO: add support for it
+ --disable-mpi
+ )
+
+ # automagic default on clang++
+ tc-export CXX
+
+ # the package doesn't use pkg-config on Linux, only on Darwin
+ # very smart of upstream...
+ append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
+ QtCore QtGui QtScript QtSvg QtXml Qt3Support )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ if ! has_version 'sci-electronics/freehdl'; then
+ elog "If you would like to be able to run digital simulations, please install:"
+ elog " sci-electronics/freehdl"
+ fi
+}