summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/mako/Manifest1
-rw-r--r--app-misc/mako/mako-1.1.ebuild32
-rw-r--r--profiles/desktop/wayland/packages3
3 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/mako/Manifest b/app-misc/mako/Manifest
new file mode 100644
index 0000000..e1c2ef6
--- /dev/null
+++ b/app-misc/mako/Manifest
@@ -0,0 +1 @@
+DIST mako-1.1.tar.gz 30551 BLAKE2B f9cdf4cad6775131f8e85279c6f5315b241b93f202e72cd6b7da9659f381260dab4702ee0461e98e82e34c071a2201a9e4a70723e466b84d589180d149428d81 SHA512 6b701a373454c30e717b1a346a100c7d5b4dfb16e0863dec5f1836b88b6e5cca0c44e54909ad38fd95f8b456a9dd8cd3fc941c175a49194df28fd4e83a664437
diff --git a/app-misc/mako/mako-1.1.ebuild b/app-misc/mako/mako-1.1.ebuild
new file mode 100644
index 0000000..940af9d
--- /dev/null
+++ b/app-misc/mako/mako-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils meson ninja-utils
+
+DESCRIPTION="A lightweight Wayland notification daemon"
+HOMEPAGE="https://wayland.emersion.fr/mako"
+
+SRC_URI="https://github.com/emersion/mako/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="elogind systemd"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/meson
+ virtual/pkgconfig"
+
+src_configure() {
+ meson_src_configure
+}
diff --git a/profiles/desktop/wayland/packages b/profiles/desktop/wayland/packages
index 18c789f..bdc409f 100644
--- a/profiles/desktop/wayland/packages
+++ b/profiles/desktop/wayland/packages
@@ -1 +1,4 @@
dev-libs/sway
+
+# Notification daemon
+app-misc/mako