summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xx11-misc/myi3lock/files/myi3lock3
-rwxr-xr-xx11-misc/myi3lock/files/mylock-notifier-fade.sh65
-rw-r--r--x11-misc/myi3lock/myi3lock-1.4.0-r1.ebuild (renamed from x11-misc/myi3lock/myi3lock-1.3.2-r1.ebuild)1
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/myi3lock/files/myi3lock b/x11-misc/myi3lock/files/myi3lock
index 0572cbc..846a249 100755
--- a/x11-misc/myi3lock/files/myi3lock
+++ b/x11-misc/myi3lock/files/myi3lock
@@ -8,6 +8,9 @@ if [ "$1" != "--login" ]; then
( sleep 3; xset dpms force off ) &
fi
+# Switch keyboard to expected layout
+ibus engine xkb:us::eng
+
# Run lock
i3lock -n -c 000000 -i "$(shuf -n1 -e "$BACKS"/*)"
diff --git a/x11-misc/myi3lock/files/mylock-notifier-fade.sh b/x11-misc/myi3lock/files/mylock-notifier-fade.sh
new file mode 100755
index 0000000..d983aee
--- /dev/null
+++ b/x11-misc/myi3lock/files/mylock-notifier-fade.sh
@@ -0,0 +1,65 @@
+#!/bin/bash
+
+# Example notifier script -- lowers screen brightness, then waits to be killed
+# and restores previous brightness on exit.
+
+## CONFIGURATION ##############################################################
+
+# Brightness will be lowered to this value.
+min_brightness=0
+
+# If your video driver works with xbacklight, set -time and -steps for fading
+# to $min_brightness here. Setting steps to 1 disables fading.
+fade_time=200
+fade_steps=20
+
+# If you have a driver without RandR backlight property (e.g. radeon), set this
+# to use the sysfs interface and create a .conf file in /etc/tmpfiles.d/
+# containing the following line to make the sysfs file writable for group
+# "users":
+#
+# m /sys/class/backlight/acpi_video0/brightness 0664 root users - -
+#
+#sysfs_path=/sys/class/backlight/acpi_video0/brightness
+
+# Time to sleep (in seconds) between increments when using sysfs. If unset or
+# empty, fading is disabled.
+fade_step_time=0.05
+
+###############################################################################
+
+get_brightness() {
+ if [[ -z $sysfs_path ]]; then
+ xbacklight -get
+ else
+ cat $sysfs_path
+ fi
+}
+
+set_brightness() {
+ if [[ -z $sysfs_path ]]; then
+ xbacklight -steps 1 -set $1
+ else
+ echo $1 > $sysfs_path
+ fi
+}
+
+fade_brightness() {
+ if [[ -z $sysfs_path ]]; then
+ xbacklight -time $fade_time -steps $fade_steps -set $1
+ elif [[ -z $fade_step_time ]]; then
+ set_brightness $1
+ else
+ local level
+ for level in $(eval echo {$(get_brightness)..$1}); do
+ set_brightness $level
+ sleep $fade_step_time
+ done
+ fi
+}
+
+trap 'exit 0' TERM INT
+trap "set_brightness $(get_brightness); kill %%" EXIT
+fade_brightness $min_brightness
+sleep 2147483647 &
+wait
diff --git a/x11-misc/myi3lock/myi3lock-1.3.2-r1.ebuild b/x11-misc/myi3lock/myi3lock-1.4.0-r1.ebuild
index 9b8caa0..64950a7 100644
--- a/x11-misc/myi3lock/myi3lock-1.3.2-r1.ebuild
+++ b/x11-misc/myi3lock/myi3lock-1.4.0-r1.ebuild
@@ -17,4 +17,5 @@ BDEPEND=""
src_install() {
dobin "${FILESDIR}/myi3lock"
+ dobin "${FILESDIR}/mylock-notifier-fade.sh"
}