summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/sway/Manifest1
-rw-r--r--dev-libs/sway/sway-1.0-r5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/sway/Manifest b/dev-libs/sway/Manifest
new file mode 100644
index 0000000..8464af6
--- /dev/null
+++ b/dev-libs/sway/Manifest
@@ -0,0 +1 @@
+DIST sway-1.0.tar.gz 5420387 BLAKE2B e1d9d0b4fa09d7427e263d847ad7ed20d9a609476859142abc5d20d4035943de9fa4e420572ae1a35fdef19039fb993ceca9ba06c8c2197e4eb01481e0d78924 SHA512 356f98bb72ceafec1c20ad156d6c928e1308f0984bb85fd748b23d61d867a79ccb4b0216a9c561b099476786f39d8e5a4b9a96571e68ca943dba52d5a19472ad
diff --git a/dev-libs/sway/sway-1.0-r5.ebuild b/dev-libs/sway/sway-1.0-r5.ebuild
new file mode 100644
index 0000000..282f00a
--- /dev/null
+++ b/dev-libs/sway/sway-1.0-r5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="http://swaywm.org/"
+
+SRC_URI="https://github.com/swaywm/sway/archive/1.0-alpha.5.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sway-1.0-alpha.5"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~arm64 ~amd64 ~x86"
+IUSE="+gdk-pixbuf +swaybar +swaybg swaygrab swaylock +swaymsg systemd +tray wallpapers zsh-completion"
+
+REQUIRED_USE="tray? ( swaybar )"
+
+RDEPEND=">=dev-libs/wlc-0.0.8[systemd=]
+ dev-libs/json-c:0=
+ dev-libs/libpcre
+ dev-libs/libinput
+ dev-libs/wayland
+ sys-libs/libcap
+ x11-libs/libxkbcommon
+ x11-libs/cairo
+ x11-libs/pango
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf[jpeg] )
+ swaylock? ( virtual/pam )
+ tray? ( sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # remove bad CFLAGS that upstream is trying to add
+ sed -i -e '/add_compile_options/s/-Werror//' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Denable-swaybar=$(usex swaybar)
+ -Denable-swaybg=$(usex swaybg)
+ -Denable-swaygrab=$(usex swaygrab)
+ -Denable-swaylock=$(usex swaylock)
+ -Denable-swaymsg=$(usex swaymsg)
+ -Denable-tray=$(usex tray)
+
+ -Ddefault-wallpaper=$(usex wallpapers)
+
+ -Denable-gdk-pixbuf=$(usex gdk-pixbuf)
+ -Dzsh-completions=$(usex zsh-completion)
+
+ -DCMAKE_INSTALL_SYSCONFDIR="/etc"
+ -DVERSION="${PV}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use !systemd && fperms u+s /usr/bin/sway
+}
+
+pkg_postinst() {
+ if use swaygrab
+ then
+ optfeature "swaygrab screenshot support" media-gfx/imagemagick[png]
+ optfeature "swaygrab video capture support" virtual/ffmpeg
+ fi
+ if use tray
+ then
+ optfeature "experimental xembed tray icons support" \
+ x11-misc/xembedsniproxy
+ fi
+
+ optfeature "X11 applications support" dev-libs/wlc[xwayland] x11-base/xorg-server[wayland]
+}