summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/cynerd-desktop/package.use2
-rw-r--r--x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/profiles/cynerd-desktop/package.use b/profiles/cynerd-desktop/package.use
index 16a1e8e..24f1238 100644
--- a/profiles/cynerd-desktop/package.use
+++ b/profiles/cynerd-desktop/package.use
@@ -1 +1,3 @@
sys-kernel/linux initramfs
+
+x11-themes/background-lnxpcs 1440p
diff --git a/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild b/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
index 4d4396e..4187865 100644
--- a/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
+++ b/x11-themes/background-lnxpcs/background-lnxpcs-0.3.ebuild
@@ -10,7 +10,7 @@ S="${WORKDIR}/lnxpcs-${HASH}"
KEYWORDS="amd64"
LICENSE="GPL-3.0+"
SLOT="0"
-IUSE=""
+IUSE="1440p"
DEPENDS="media-gfx/imagemagick[png]"
RDEPEND="
@@ -20,8 +20,12 @@ RDEPEND="
WALLPAPERS="bash cron gcc gnu gnu-linux iptables kernel kill python root su sudo vim"
src_compile() {
+ local RESOL="1920 1080"
+ if use 1440p; then
+ RESOL="2560 1440"
+ fi
for IMG in $WALLPAPERS; do
- ./makemywall 1920 1080 "cards/black/$IMG-card-black.png"
+ ./makemywall $RESOL "cards/black/$IMG-card-black.png"
done
}