summaryrefslogtreecommitdiff
path: root/x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-01-21 21:47:49 +0100
committerKarel Kočí <cynerd@email.cz>2019-01-21 21:47:49 +0100
commit81adae0877faea4b21edf137752a5c085aa115f4 (patch)
tree808e89809b660a3667b269d5c336231910097f87 /x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild
parent704051ea9c80197618aa5e22cc0fd45eed46cfa0 (diff)
downloadgentoo-personal-overlay-81adae0877faea4b21edf137752a5c085aa115f4.tar.gz
gentoo-personal-overlay-81adae0877faea4b21edf137752a5c085aa115f4.tar.bz2
gentoo-personal-overlay-81adae0877faea4b21edf137752a5c085aa115f4.zip
x11-themes/numix-frost: try to fix dependency
Use specifically ruby 3.5.
Diffstat (limited to 'x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild')
-rw-r--r--x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild b/x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild
new file mode 100644
index 0000000..a7c0eb7
--- /dev/null
+++ b/x11-themes/numix-frost/numix-frost-3.6.6-r3.ebuild
@@ -0,0 +1,40 @@
+EAPI=6
+
+DESCRIPTION="Numix is a modern flat theme with a combination of light and dark elements."
+HOMEPAGE="https://github.com/Antergos/Numix-Frost"
+
+# Note: We need few more commits to fix some build problems
+# But those contains binary files patches that can't portage handle so we just
+# specify exact hash instead. When new version is release, return to versions.
+HASH="e9d250792bced3b64c50e72c4f3404a2c020dc3e"
+SRC_URI="https://github.com/Antergos/Numix-Frost/archive/${HASH}.tar.gz -> ${PN}.tar.gz"
+S="${WORKDIR}/numix-frost"
+
+KEYWORDS="amd64"
+LICENSE="GPL-3.0+"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ruby/sass:3.5
+ dev-ruby/bundler"
+RDEPEND="
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ x11-themes/gtk-engines-murrine"
+
+# Note: This is needed because utils.sh expect repository name to be numix-frost
+src_unpack() {
+ unpack "${A}"
+ mv "${WORKDIR}"/Numix-Frost-${HASH} "$S"
+}
+
+src_compile() {
+ emake -j1
+}
+
+# Jep and makefiles doesn't like to be run in paralel (you have to love it)
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}