summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-06-28 11:29:42 +0200
committerKarel Kočí <cynerd@email.cz>2021-06-28 11:29:42 +0200
commit4405a705b973d6bbc73eeefb887bec25d30fa10f (patch)
tree4edd8a29d4db52fe8d16a83bbcf119b498d96893 /x11-libs
parent1ae8d113c27b32a2eb0087859109d363fbd2dd48 (diff)
downloadgentoo-personal-overlay-4405a705b973d6bbc73eeefb887bec25d30fa10f.tar.gz
gentoo-personal-overlay-4405a705b973d6bbc73eeefb887bec25d30fa10f.tar.bz2
gentoo-personal-overlay-4405a705b973d6bbc73eeefb887bec25d30fa10f.zip
x11-libs/goocanvas: update to 3.0.0
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goocanvas/Manifest1
-rw-r--r--x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch26
-rw-r--r--x11-libs/goocanvas/goocanvas-3.0.0-r1.ebuild56
3 files changed, 83 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/Manifest b/x11-libs/goocanvas/Manifest
new file mode 100644
index 0000000..0ef8de1
--- /dev/null
+++ b/x11-libs/goocanvas/Manifest
@@ -0,0 +1 @@
+DIST goocanvas-3.0.0.tar.xz 556832 BLAKE2B 4ee632a614b6b881000bbee8d5e21a166151a94667c603c92b94c5e076fab78a6df44fe1d45fb4d7c4d65c0e060b599abf3970313542836a63efbca33d6a075b SHA512 a53839af4d98afdfc0f92531bdb09013dd71e964185dc2670af077bb7b41b9ff5c75f2801f6e77c99055b38f3603d8cf197f84affb8d7c3196526ce824b228e3
diff --git a/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch b/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch
new file mode 100644
index 0000000..c395c6f
--- /dev/null
+++ b/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch
@@ -0,0 +1,26 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b49c009..9c3316b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -12,7 +12,7 @@ INCLUDES = \
+
+ lib_LTLIBRARIES = libgoocanvas.la
+
+-libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+
+ if PLATFORM_WIN32
+ no_undefined = -no-undefined
+diff --git a/src/Makefile.in b/src/Makefile.in
+index c4d43b2..8d555fe 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -254,7 +254,7 @@ INCLUDES = \
+ # -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ # -DGTK_DISABLE_DEPRECATED
+ lib_LTLIBRARIES = libgoocanvas.la
+-libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+ @PLATFORM_WIN32_TRUE@no_undefined = -no-undefined
+ libtool_opts = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/x11-libs/goocanvas/goocanvas-3.0.0-r1.ebuild b/x11-libs/goocanvas/goocanvas-3.0.0-r1.ebuild
new file mode 100644
index 0000000..4560a2d
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-3.0.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc ppc64 sparc x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.16
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed failed"
+
+ # Python bindings are built/installed manually, but not at all anymore (py2).
+ sed -e "/SUBDIRS = python/d" -i bindings/Makefile.am bindings/Makefile.in
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}