summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-12-03 12:48:28 +0100
committerKarel Kočí <cynerd@email.cz>2017-12-03 12:48:28 +0100
commitb1f813fef6cc8e14affce51c99f98d2d019ea485 (patch)
tree38eb517e7ac888676b3eea1e3d675cf1c3058eb9 /www-client
parenteb24cc5a0bfd1f3d34ebe6b8e397da149f2151de (diff)
downloadgentoo-personal-overlay-b1f813fef6cc8e14affce51c99f98d2d019ea485.tar.gz
gentoo-personal-overlay-b1f813fef6cc8e14affce51c99f98d2d019ea485.tar.bz2
gentoo-personal-overlay-b1f813fef6cc8e14affce51c99f98d2d019ea485.zip
Add my own surf
Diffstat (limited to 'www-client')
-rw-r--r--www-client/surf/surf-2.0m1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-client/surf/surf-2.0m1-r1.ebuild b/www-client/surf/surf-2.0m1-r1.ebuild
new file mode 100644
index 0000000..8fb493b
--- /dev/null
+++ b/www-client/surf/surf-2.0m1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="https://surf.suckless.org/"
+SRC_URI="http://git.cynerd.cz/surf/snapshot/${PN}-${VER}.tar.gz"
+S="${WORKDIR}/surf-${VER}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ net-libs/libsoup
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ app-crypt/gcr
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ net-misc/curl
+"
+
+src_prepare() {
+ default
+ tc-export CC PKG_CONFIG
+}