summaryrefslogtreecommitdiff
path: root/www-apps/radicale/radicale-2.1.8.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-01-28 01:27:54 +0100
committerKarel Kočí <cynerd@email.cz>2018-01-28 01:27:54 +0100
commit02ceacddddac2b3b708b06e25ac30c2da893fa5f (patch)
tree719ecee8ebf357dd50ff9ac720bed4b8b7a46bdc /www-apps/radicale/radicale-2.1.8.ebuild
parent5ecfd9d359f7b95f9ac143450ee6342943f03e08 (diff)
downloadgentoo-personal-overlay-02ceacddddac2b3b708b06e25ac30c2da893fa5f.tar.gz
gentoo-personal-overlay-02ceacddddac2b3b708b06e25ac30c2da893fa5f.tar.bz2
gentoo-personal-overlay-02ceacddddac2b3b708b06e25ac30c2da893fa5f.zip
Try to update radicale
Diffstat (limited to 'www-apps/radicale/radicale-2.1.8.ebuild')
-rw-r--r--www-apps/radicale/radicale-2.1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-apps/radicale/radicale-2.1.8.ebuild b/www-apps/radicale/radicale-2.1.8.ebuild
new file mode 100644
index 0000000..19e37d0
--- /dev/null
+++ b/www-apps/radicale/radicale-2.1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit eutils distutils-r1 user
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+SRC_URI="https://github.com/Kozea/Radicale/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~x86"
+IUSE=""
+
+UDIR=/var/lib/radicale
+
+pkg_setup() {
+ enewgroup radicale
+ enewuser radicale -1 -1 ${UDIR} radicale
+}
+
+python_install_all() {
+ # init file
+ newinitd "${FILESDIR}"/radicale.init.d radicale
+
+ # directories
+ diropts -m0750
+ dodir ${UDIR}
+ fowners radicale:radicale ${UDIR}
+
+ distutils-r1_python_install_all
+}