summaryrefslogtreecommitdiff
path: root/sys-kernel/linux
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-05-24 11:24:29 +0200
committerKarel Kočí <cynerd@email.cz>2017-05-24 11:24:29 +0200
commit812b0ac6d8472dd179ee7a2dab0205147d5d9fc6 (patch)
tree18eec305976e0c5b9c641232bd7a3172757792ee /sys-kernel/linux
parent9f07a2de0c9a01ccde842526790a35e97cd8dddb (diff)
downloadgentoo-personal-overlay-812b0ac6d8472dd179ee7a2dab0205147d5d9fc6.tar.gz
gentoo-personal-overlay-812b0ac6d8472dd179ee7a2dab0205147d5d9fc6.tar.bz2
gentoo-personal-overlay-812b0ac6d8472dd179ee7a2dab0205147d5d9fc6.zip
Add linux v4.11.2 and small fix in source linkage
Diffstat (limited to 'sys-kernel/linux')
-rw-r--r--sys-kernel/linux/linux-4.11.2-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-kernel/linux/linux-4.11.2-r1.ebuild b/sys-kernel/linux/linux-4.11.2-r1.ebuild
new file mode 100644
index 0000000..9c7bac5
--- /dev/null
+++ b/sys-kernel/linux/linux-4.11.2-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-stable-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-boot/myinitramfs"
+
+src_configure() {
+ # Fix ARCH variable
+ [ "$ARCH" = "amd64" ] && ARCH="x86"
+
+ "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
+}
+
+src_install() {
+ emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
+
+ dodir /boot
+ insinto /boot
+ newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+ # Package source (kind of annoying because of some packages expecting it)
+ emake clean
+ dodir /usr/src
+ cp -a "${S}" "${D}/usr/src/linux-${PV}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+ (
+ cd "${ROOT}/usr/src"
+ rm -f linux
+ ln -s $(ls | grep "linux-" | sort | head -1) linux
+ )
+}
+
+pkg_postinst() {
+ # Add label to syslinux config if there is non yet
+ SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+ if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+ ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+ if [ -n "$ARGS" ]; then
+ sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+ else
+ eerror "Adding label to syslinux configuration failed as there are no arguments"
+ fi
+ fi
+ src_link
+}
+
+pkg_prerm() {
+ # Remove label from syslinux config
+ sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+ src_link
+}