summaryrefslogtreecommitdiff
path: root/sys-kernel/linux
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-06-02 09:59:17 +0200
committerKarel Kočí <cynerd@email.cz>2017-06-02 09:59:17 +0200
commit7dc74b94ec8864f4aa9d221816eadc054e090d7f (patch)
tree337fccbafec3f12d22143c74ea69d57f50564d17 /sys-kernel/linux
parentee11bb7533c3dc5d39b725881cac04542f575d3c (diff)
downloadgentoo-personal-overlay-7dc74b94ec8864f4aa9d221816eadc054e090d7f.tar.gz
gentoo-personal-overlay-7dc74b94ec8864f4aa9d221816eadc054e090d7f.tar.bz2
gentoo-personal-overlay-7dc74b94ec8864f4aa9d221816eadc054e090d7f.zip
Add recovery mode for myinitramfs
Diffstat (limited to 'sys-kernel/linux')
-rw-r--r--sys-kernel/linux/linux-4.11.3-r2.ebuild (renamed from sys-kernel/linux/linux-4.11.3-r1.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-kernel/linux/linux-4.11.3-r1.ebuild b/sys-kernel/linux/linux-4.11.3-r2.ebuild
index cece624..0dcdd3e 100644
--- a/sys-kernel/linux/linux-4.11.3-r1.ebuild
+++ b/sys-kernel/linux/linux-4.11.3-r2.ebuild
@@ -56,6 +56,7 @@ pkg_postinst() {
ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
if [ -n "$ARGS" ]; then
sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+ sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
else
eerror "Adding label to syslinux configuration failed as there are no arguments"
fi
@@ -65,7 +66,7 @@ pkg_postinst() {
pkg_prerm() {
# Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
+ sed -i "/^LABEL gentoo-${PV}(|-recovery)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
}
pkg_postrm() {