summaryrefslogtreecommitdiff
path: root/sys-kernel/linux
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2017-07-03 18:54:41 +0200
committerKarel Kočí <karel.koci@nic.cz>2017-07-03 18:54:41 +0200
commit7577ddda7986a8785b6798fdcea1eceb5af41d3a (patch)
tree67bae58dc2ade016a342a24c9bb0fc0a3c12cec6 /sys-kernel/linux
parent3c401ccbedd9e5196d7bb8906868e721b9a660d2 (diff)
downloadgentoo-personal-overlay-7577ddda7986a8785b6798fdcea1eceb5af41d3a.tar.gz
gentoo-personal-overlay-7577ddda7986a8785b6798fdcea1eceb5af41d3a.tar.bz2
gentoo-personal-overlay-7577ddda7986a8785b6798fdcea1eceb5af41d3a.zip
Linux 4.11.8
Diffstat (limited to 'sys-kernel/linux')
-rw-r--r--sys-kernel/linux/Manifest3
-rw-r--r--sys-kernel/linux/linux-4.11.7-r1.ebuild74
-rw-r--r--sys-kernel/linux/linux-4.11.8-r1.ebuild (renamed from sys-kernel/linux/linux-4.11.6-r2.ebuild)0
3 files changed, 1 insertions, 76 deletions
diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 346153b..cf04cae 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1,2 +1 @@
-DIST linux-4.11.6.tar.gz 147169967 SHA256 ddab77cf00eb6f439366f9373b34181d1fcdc9a72fe2155af572ff832ba55441 SHA512 d8ae8c51878120e713a9bec7938463ffcdc53d2c8a05bfd90e7db3f405f6aa972c61a1b0639afc5c9a5b3f90cc316e5a2bf0e3e68f5d01b4d7aa84561d09091c WHIRLPOOL 66737c48e1aa23d733cdc29f4b3a2dafa2e6b01398ff7d253bb0746cb55f2d1b57bb7a3673df64b4972216e5ed7addb22ae2707aeb33dcc7a23ed7b36d5a0f8b
-DIST linux-4.11.7.tar.gz 147164713 SHA256 7004ad0746f5e27de3aff68ca0db316bf95d2903da09d0eb86c357069887448f SHA512 1dc3643bc1949fc3833336931e0f28d4e5aabc0bdd0e8e37a1ae383597a9dbd1634c40bf98f8438ce6bac00db39bdd7d211274fe091182b687ad274942894931 WHIRLPOOL 839338c1b15b74166d779fe2314708e6b83a95b116f196d4df711948c03c86c8010661d7b43bc051be1461dc890f0e195f0fee6f3e1d54f8278a9f24ad8e835d
+DIST linux-4.11.8.tar.gz 147171580 SHA256 b6bc5ec37ebc58a6e1f3b9a4eec5d519e42bf757a16ce0d46f36e91b1d95af56 SHA512 3d21c27af284c14d95f7ec37329c858793bd7f8287ac423cdb1a169bc1f4d2f12e83c41ae7f91cfb47b1724b7acc6d335a8bc7a61c970b1b88689ca593e3f10f WHIRLPOOL a70ba837fef24b27e3a2a48cb31b563bfc6dd36243df6a0c1e88111d77346d027afa4ad0e609fce740ec31ca136625fbcfd6060d4f16687317efdabfbd199b6d
diff --git a/sys-kernel/linux/linux-4.11.7-r1.ebuild b/sys-kernel/linux/linux-4.11.7-r1.ebuild
deleted file mode 100644
index 0dcdd3e..0000000
--- a/sys-kernel/linux/linux-4.11.7-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-boot/myinitramfs"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}(|-recovery)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}
diff --git a/sys-kernel/linux/linux-4.11.6-r2.ebuild b/sys-kernel/linux/linux-4.11.8-r1.ebuild
index 0dcdd3e..0dcdd3e 100644
--- a/sys-kernel/linux/linux-4.11.6-r2.ebuild
+++ b/sys-kernel/linux/linux-4.11.8-r1.ebuild