summaryrefslogtreecommitdiff
path: root/sys-kernel/linux/linux-4.16.15-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-06-28 23:56:24 +0200
committerKarel Kočí <cynerd@email.cz>2018-06-28 23:56:24 +0200
commita1c8e413cd73dec8aab59c06d8b49ffb9bfc9523 (patch)
tree8e77811a4ba46a83bd2815120e63461f4757a975 /sys-kernel/linux/linux-4.16.15-r1.ebuild
parentf349445971b35bdfff57a131eeccc17c5e558755 (diff)
downloadgentoo-personal-overlay-a1c8e413cd73dec8aab59c06d8b49ffb9bfc9523.tar.gz
gentoo-personal-overlay-a1c8e413cd73dec8aab59c06d8b49ffb9bfc9523.tar.bz2
gentoo-personal-overlay-a1c8e413cd73dec8aab59c06d8b49ffb9bfc9523.zip
sys-kernel/linux: update to v4.16.18
Diffstat (limited to 'sys-kernel/linux/linux-4.16.15-r1.ebuild')
-rw-r--r--sys-kernel/linux/linux-4.16.15-r1.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/sys-kernel/linux/linux-4.16.15-r1.ebuild b/sys-kernel/linux/linux-4.16.15-r1.ebuild
deleted file mode 100644
index a450a55..0000000
--- a/sys-kernel/linux/linux-4.16.15-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="virt initramfs amd intel"
-
-DEPEND="
- sys-devel/bc
- dev-libs/elfutils"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
- || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-sysfile() {
- if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- PFIX=".."
- elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
- SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
- PFIX="../../.."
- elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
- SYSLINUX="${ROOT}/boot/extlinux.conf"
- PFIX="."
- else
- eerror "Can't locate syslinux configuration!"
- fi
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- sysfile
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- if $(use initramfs); then
- INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
- fi
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
-
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sysfile
- sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}