summaryrefslogtreecommitdiff
path: root/sys-kernel/linux/linux-4.11.1-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-05-30 19:30:10 +0200
committerKarel Kočí <cynerd@email.cz>2017-05-30 19:30:10 +0200
commitee11bb7533c3dc5d39b725881cac04542f575d3c (patch)
treee4f956418280f26bb9ddf8f3b9d25fe452024773 /sys-kernel/linux/linux-4.11.1-r1.ebuild
parentce2da29185a6e1f72a2cc5b142d6922548c98f96 (diff)
downloadgentoo-personal-overlay-ee11bb7533c3dc5d39b725881cac04542f575d3c.tar.gz
gentoo-personal-overlay-ee11bb7533c3dc5d39b725881cac04542f575d3c.tar.bz2
gentoo-personal-overlay-ee11bb7533c3dc5d39b725881cac04542f575d3c.zip
linux v4.11.3
Diffstat (limited to 'sys-kernel/linux/linux-4.11.1-r1.ebuild')
-rw-r--r--sys-kernel/linux/linux-4.11.1-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/sys-kernel/linux/linux-4.11.1-r1.ebuild b/sys-kernel/linux/linux-4.11.1-r1.ebuild
deleted file mode 100644
index cece624..0000000
--- a/sys-kernel/linux/linux-4.11.1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-boot/myinitramfs"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}