summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-05-02 20:21:54 +0200
committerKarel Kočí <cynerd@email.cz>2017-05-02 20:21:54 +0200
commit6e88426a126b899d247c14828c81ab73fd6a9a60 (patch)
treee520b9724a96d6a52616c120defd8c082c17fabd /sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild
parent0bbb82840d84e37d70c53a795bf1c05fb1518612 (diff)
downloadgentoo-personal-overlay-6e88426a126b899d247c14828c81ab73fd6a9a60.tar.gz
gentoo-personal-overlay-6e88426a126b899d247c14828c81ab73fd6a9a60.tar.bz2
gentoo-personal-overlay-6e88426a126b899d247c14828c81ab73fd6a9a60.zip
Some fixes
Diffstat (limited to 'sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild')
-rw-r--r--sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild b/sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild
new file mode 100644
index 0000000..8c7fbde
--- /dev/null
+++ b/sys-kernel/linux-rb2/linux-rb2-4.10.13-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GIT_REV="b957be36d793c59c5a12d1f00419c253d38dde1f"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://codeload.github.com/raspberrypi/linux/zip/${GIT_REV}.zip -> ${P}.zip"
+S="${WORKDIR}/linux-${GIT_REV}"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ emake bcm2709_defconfig
+}
+
+src_install() {
+ emake zinstall modules_install dtbs_install INSTALL_PATH="${D}" INSTALL_MOD_PATH="${D}"
+}