summaryrefslogtreecommitdiff
path: root/sys-devel
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-09 12:35:39 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-09 12:35:39 +0100
commit49ede2ae49665bce64ecdbfd09c920003f4dbaa3 (patch)
tree84c2a29b5704a5870e02496e1daab7c1031ad3a3 /sys-devel
parent422a39358490b6afefd464c7e5dcaf3cbe122f4e (diff)
downloadgentoo-personal-overlay-49ede2ae49665bce64ecdbfd09c920003f4dbaa3.tar.gz
gentoo-personal-overlay-49ede2ae49665bce64ecdbfd09c920003f4dbaa3.tar.bz2
gentoo-personal-overlay-49ede2ae49665bce64ecdbfd09c920003f4dbaa3.zip
sys-devel/ct-ng: try to fix build
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/Manifest1
-rw-r--r--sys-devel/ct-ng/ct-ng-1.23.0-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/Manifest b/sys-devel/ct-ng/Manifest
new file mode 100644
index 0000000..4e2f05d
--- /dev/null
+++ b/sys-devel/ct-ng/Manifest
@@ -0,0 +1 @@
+DIST crosstool-ng-1.23.0.tar.bz2 1782247 BLAKE2B 77835534b5b664148985b57580bf24fa6153e1fc327be0622e55d9ff5c1c5f446039b293a7d1718bfbec89789638f80033be012e0878f75a57648bd574abe10e SHA512 1842d140b1c4f76783751eab60722e8077f356dfc9e9cc941d3c991a7e9bb23cb19e6bd7cd5c630cc87967853c55e0c16e415b222e546b5baaffb264ca799b69
diff --git a/sys-devel/ct-ng/ct-ng-1.23.0-r1.ebuild b/sys-devel/ct-ng/ct-ng-1.23.0-r1.ebuild
new file mode 100644
index 0000000..ae22277
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.23.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="https://crosstool-ng.github.io/"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_configure() {
+ ./bootstrap
+ autotools-utils_src_configure
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}