summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-09-02 15:55:22 +0200
committerKarel Kočí <cynerd@email.cz>2021-09-02 15:55:22 +0200
commit4bc26a55e65275522d0b9723901d9d198b5b6ce9 (patch)
treee3cd29268699e575bea44b0f66161c90e38da894 /sys-boot
parentbc16b096567b888c420f814e2ae7a1dd973470d0 (diff)
downloadgentoo-personal-overlay-4bc26a55e65275522d0b9723901d9d198b5b6ce9.tar.gz
gentoo-personal-overlay-4bc26a55e65275522d0b9723901d9d198b5b6ce9.tar.bz2
gentoo-personal-overlay-4bc26a55e65275522d0b9723901d9d198b5b6ce9.zip
sys-boot/myinitramfs: try to fix issues
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/myinitramfs/files/baselist4
-rwxr-xr-xsys-boot/myinitramfs/files/init.enc6
-rw-r--r--sys-boot/myinitramfs/myinitramfs-1.5.7-r1.ebuild (renamed from sys-boot/myinitramfs/myinitramfs-1.5.6-r1.ebuild)0
3 files changed, 7 insertions, 3 deletions
diff --git a/sys-boot/myinitramfs/files/baselist b/sys-boot/myinitramfs/files/baselist
index 2461b72..692a560 100644
--- a/sys-boot/myinitramfs/files/baselist
+++ b/sys-boot/myinitramfs/files/baselist
@@ -6,6 +6,7 @@ dir /lib64 755 0 0
dir /etc 755 0 0
dir /dev 755 0 0
dir /proc 755 0 0
+dir /run 755 0 0
dir /sys 755 0 0
dir /root 755 0 0
dir /usr 755 0 0
@@ -15,8 +16,9 @@ dir /usr/lib64 755 0 0
dir /mnt 755 0 0
dir /mnt/root 755 0 0
-# Ld
+# Ld and gcc library
file /lib64/ld-linux-x86-64.so.2 /lib64/ld-linux-x86-64.so.2 755 0 0
+file /usr/lib64/libgcc_s.so.1 /usr/lib64/libgcc_s.so.1 0 0
# Busybox
file /bin/busybox /bin/busybox 755 0 0
diff --git a/sys-boot/myinitramfs/files/init.enc b/sys-boot/myinitramfs/files/init.enc
index 1fea03a..0f8c85d 100755
--- a/sys-boot/myinitramfs/files/init.enc
+++ b/sys-boot/myinitramfs/files/init.enc
@@ -31,8 +31,10 @@ fail() {
echo -e "${C_GRAY}Mount root to /mnt/root and exit shell to switch root.${C_NO}"
# Note: this is hack to enable job control
setsid sh -c 'exec sh </dev/tty1 >/dev/tty1 2>&1'
- echo
- exec switch_root /mnt/root /sbin/init || echo -e "${C_RED}Root switch failed!${C_NO}"
+ if [ -f /mnt/root/sbin/init ]; then
+ exec switch_root /mnt/root /sbin/init
+ fi
+ echo -e "${C_RED}Are you sure that you mounted root filesystem?${C_NO}"
done
}
diff --git a/sys-boot/myinitramfs/myinitramfs-1.5.6-r1.ebuild b/sys-boot/myinitramfs/myinitramfs-1.5.7-r1.ebuild
index 2cb3f91..2cb3f91 100644
--- a/sys-boot/myinitramfs/myinitramfs-1.5.6-r1.ebuild
+++ b/sys-boot/myinitramfs/myinitramfs-1.5.7-r1.ebuild