summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-30 17:54:08 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-30 17:54:59 +0200
commit2e742443020ede65794696c8e085e10ee9f60dbc (patch)
treeca6d30a469bc1091a9fc1fc18d8a73aa0da72fee /sys-boot
parent4cb3fef9b0f6b1902e55059923c54e23df007adf (diff)
downloadgentoo-personal-overlay-2e742443020ede65794696c8e085e10ee9f60dbc.tar.gz
gentoo-personal-overlay-2e742443020ede65794696c8e085e10ee9f60dbc.tar.bz2
gentoo-personal-overlay-2e742443020ede65794696c8e085e10ee9f60dbc.zip
Add linux entry to syslinux
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
index e126e0d..689d5a2 100644
--- a/sys-boot/linux/linux-4.10.13.ebuild
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -25,9 +25,6 @@ src_configure() {
src_install() {
emake modules_install INSTALL_MOD_PATH="${D}"
- # These aren't correct anyway
- rm "${D}/lib64/modules/${PV}/source"
- rm "${D}/lib64/modules/${PV}/build"
dodir /boot
insinto /boot
@@ -35,11 +32,11 @@ src_install() {
}
src_postinst() {
- # TODO add this to syslinux.cnf
- true
+ # Add label to syslinux config
+ sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND root=/dev/sda2 rootflags=subvol=@gentoo\n\tINITRD ../initramfs-gentoo\n" /boot/syslinux/syslinux.cnf
}
src_prerm() {
- # TODO remove this from syslinux.cnf
- true
+ # Remove label from syslinux config
+ sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cnf
}