summaryrefslogtreecommitdiff
path: root/sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-04-11 23:43:41 +0200
committerKarel Kočí <cynerd@email.cz>2018-04-11 23:43:41 +0200
commit6755a9d18d81844b50599ab032b4de99a15be6f6 (patch)
tree16c5b2e0b637d36503f63ea0328b5eb70c2226f6 /sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild
parent5250c10f9497725f92fdbb14521050cd4e90d42b (diff)
downloadgentoo-personal-overlay-6755a9d18d81844b50599ab032b4de99a15be6f6.tar.gz
gentoo-personal-overlay-6755a9d18d81844b50599ab032b4de99a15be6f6.tar.bz2
gentoo-personal-overlay-6755a9d18d81844b50599ab032b4de99a15be6f6.zip
myinitramfs: fix init for rootuuid
Diffstat (limited to 'sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild')
-rw-r--r--sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild b/sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild
new file mode 100644
index 0000000..e31efdc
--- /dev/null
+++ b/sys-boot/myinitramfs/myinitramfs-1.4.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO support encrytion and btrfs only as option
+
+EAPI=6
+
+VER="${PV%-r*}"
+
+DESCRIPTION="My personal initramfs (verry simple with encryption support)"
+S="${WORKDIR}/myinitramfs-${VER}"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-fs/cryptsetup
+sys-fs/btrfs-progs
+sys-apps/linux-misc-apps
+sys-apps/busybox[static]"
+RDEPEND="${DEPEND}
+sys-kernel/linux[initramfs]"
+
+src_unpack() {
+ # Well we have no sources so just create empty directory
+ mkdir -p "${S}"
+}
+
+src_compile() {
+ "${FILESDIR}/gen.sh" initramfs-gentoo
+}
+
+src_install() {
+ dodir /boot
+ insinto /boot
+ newins initramfs-gentoo initramfs-gentoo
+}