summaryrefslogtreecommitdiff
path: root/sys-boot/linux/linux-4.10.13.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-28 22:30:14 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-29 11:09:39 +0200
commitff32725fff6b3bd40a87f0b21152764084f9d33a (patch)
tree8d118a03310cbc96dd98ddea1f2108f826ff1e6a /sys-boot/linux/linux-4.10.13.ebuild
parent13f491a430735286fecb767ca0abe5d1ab42c046 (diff)
downloadgentoo-personal-overlay-ff32725fff6b3bd40a87f0b21152764084f9d33a.tar.gz
gentoo-personal-overlay-ff32725fff6b3bd40a87f0b21152764084f9d33a.tar.bz2
gentoo-personal-overlay-ff32725fff6b3bd40a87f0b21152764084f9d33a.zip
Add package for linux
Diffstat (limited to 'sys-boot/linux/linux-4.10.13.ebuild')
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
new file mode 100644
index 0000000..b37508c
--- /dev/null
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-stable-${PV}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="bluetooth
+desktop
+ikconfig
+kvm
+network
+power
+sd_storage"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ [ "$ARCH" = "amd64" ] && ARCH="x86"
+
+ emake mrproper
+ # TODO support cross compile
+ # Generate default configuration
+ emake defconfig
+
+ # Apply configuration
+ (
+ ARGS=""
+ for U in $IUSE; do
+ ARGS="$ARGS $(usev $U)"
+ done
+ cd "${S}"
+ "${FILESDIR}"/config_prepare.sh $ARGS
+ )
+
+ # Process changes
+ emake olddefconfig
+
+ # Check changes
+ EOUT="$("${FILESDIR}"/config_miss.sh $ARGS)"
+ if [ $? -ne 0 ]; then
+ eerror "Configuration failed:
+$EOUT"
+ fail
+ fi
+}
+
+src_install() {
+ emake modules_install INSTALL_MOD_PATH="${D}"
+
+ dodir /boot
+ insinto /boot
+ newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+}
+
+src_postinst() {
+ # TODO add this to syslinux.cnf
+ true
+}
+
+src_prerm() {
+ # TODO remove this from syslinux.cnf
+ true
+}