summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-06-15 16:41:11 +0200
committerKarel Kočí <cynerd@email.cz>2018-06-15 16:41:11 +0200
commit508bdde004ccdfc2d5045d9e5de0a9f15ca728e1 (patch)
treea12d6de5e3a206eb45d73dc234afc48e7ec571a5 /sys-apps
parent310823a7bd2304ec5cbdaecc1e664f41769e3421 (diff)
downloadgentoo-personal-overlay-508bdde004ccdfc2d5045d9e5de0a9f15ca728e1.tar.gz
gentoo-personal-overlay-508bdde004ccdfc2d5045d9e5de0a9f15ca728e1.tar.bz2
gentoo-personal-overlay-508bdde004ccdfc2d5045d9e5de0a9f15ca728e1.zip
sys-app/shellrc: update to version 0.4
Use install script
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shellrc/Manifest2
-rw-r--r--sys-apps/shellrc/shellrc-0.3-r1.ebuild41
-rw-r--r--sys-apps/shellrc/shellrc-0.4-r1.ebuild25
3 files changed, 26 insertions, 42 deletions
diff --git a/sys-apps/shellrc/Manifest b/sys-apps/shellrc/Manifest
index 62805e6..2320a3a 100644
--- a/sys-apps/shellrc/Manifest
+++ b/sys-apps/shellrc/Manifest
@@ -1 +1 @@
-DIST shellrc-0.3.tar.gz 3952 BLAKE2B 3a7122fa5bf92eeea94b1ad286b472590041bae4fce46d98aa869475cdecd7119f4f3d18f014048e1362290511e5da21bd0f9ab39a9ebde70a863d6d002b47d6 SHA512 ec20491eb20fec709c755e685ac00ebea5b6f7989c9d37382971ff5545811b73cbd9346961d43dcb507b05d046794efdc8578bbbce2ef219fc1027dcf10370c2
+DIST shellrc-0.4.tar.gz 4436 BLAKE2B 9d123bfd2dbf9ee60562fe4eefeaa075c932b9568114aeae206c07c47e7d8fafd50a9886fc7f8ba7574b84ac3196c397ef348298f345c57299d4aa3dc528f3c7 SHA512 7030fc4eb7151dacc250ce727aa46b69c99971333c13d9d9df930d9c08eb4fa54c1ed568592e2c10331a4ec3e2ed93f308a72a6654ff6e9bc8575e94839c757f
diff --git a/sys-apps/shellrc/shellrc-0.3-r1.ebuild b/sys-apps/shellrc/shellrc-0.3-r1.ebuild
deleted file mode 100644
index 9f32ce6..0000000
--- a/sys-apps/shellrc/shellrc-0.3-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-EAPI=6
-
-DESCRIPTION="Shell initialization files"
-HOMEPAGE="https://git.cynerd.cz/shellrc/"
-SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3.0+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="desktop +zsh +bash"
-
-DEPEND="zsh? ( app-shells/zsh )
- bash? ( app-shells/bash )
- desktop? ( x11-misc/xclip media-gfx/imagemagick )
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- dodir /etc
- insinto /etc
- doins -r "${S}/shellrc.d"
-
- if use bash; then
- dodir /etc/bash/bashrc.d
- insinto /etc/bash
- doins -r "${S}/bashrc.d"
- dodir /usr/share/bash-completion/completions
- insinto /usr/share/bash-completion/completions
- doins -r "${S}"/bash-completion/*
- fi
-
- if use zsh; then
- dodir /etc/zsh
- insinto /etc/zsh
- doins "${S}/zshrc"
- doins -r "${S}/zshrc.d"
- dodir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/site-functions
- doins -r "${S}"/zsh-completion/*
- fi
-}
diff --git a/sys-apps/shellrc/shellrc-0.4-r1.ebuild b/sys-apps/shellrc/shellrc-0.4-r1.ebuild
new file mode 100644
index 0000000..47c193c
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.4-r1.ebuild
@@ -0,0 +1,25 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop +zsh +bash"
+
+DEPEND="zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=""
+ use bash && args="$args --bash" || true
+ use zsh && args="$args --zsh" || true
+ # TODO desktop
+
+ "${S}/install" --prefix "${D}" $args
+}