summaryrefslogtreecommitdiff
path: root/sys-apps/shellrc/shellrc-0.7.6-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-04-24 07:41:30 +0200
committerKarel Kočí <cynerd@email.cz>2020-04-24 07:41:30 +0200
commit8050eff1c9b390f64b43991e3638a59fb91afcf7 (patch)
tree6980fd31499affc783b7ed488deaadc663d586ff /sys-apps/shellrc/shellrc-0.7.6-r1.ebuild
parent2bbfe09c066243ebb1fe0650eb5833e3cc0d7f36 (diff)
downloadgentoo-personal-overlay-8050eff1c9b390f64b43991e3638a59fb91afcf7.tar.gz
gentoo-personal-overlay-8050eff1c9b390f64b43991e3638a59fb91afcf7.tar.bz2
gentoo-personal-overlay-8050eff1c9b390f64b43991e3638a59fb91afcf7.zip
sys-apps/shellrc: update to version 0.7.6
Diffstat (limited to 'sys-apps/shellrc/shellrc-0.7.6-r1.ebuild')
-rw-r--r--sys-apps/shellrc/shellrc-0.7.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/shellrc/shellrc-0.7.6-r1.ebuild b/sys-apps/shellrc/shellrc-0.7.6-r1.ebuild
new file mode 100644
index 0000000..f9dcd5d
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.7.6-r1.ebuild
@@ -0,0 +1,28 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop xorg +zsh +bash"
+
+DEPEND="
+ zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( sys-fs/inotify-tools )
+ xorg? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=""
+ use bash && args="$args --bash" || true
+ use zsh && args="$args --zsh" || true
+ use desktop && args="$args --desktop" || true
+ # TODO xorg
+
+ "${S}/install" --prefix "${D}" $args
+}