summaryrefslogtreecommitdiff
path: root/sys-apps/shellrc/shellrc-0.5-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-02 13:58:51 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-02 13:58:51 +0200
commit45a73b68a0f9ebe58b42b12335e33c065b65821d (patch)
treeac5481e74afcfd4829057ee717499be98b953812 /sys-apps/shellrc/shellrc-0.5-r1.ebuild
parenteab6d558304d06a008202084c057bc0c05e9c930 (diff)
downloadgentoo-personal-overlay-45a73b68a0f9ebe58b42b12335e33c065b65821d.tar.gz
gentoo-personal-overlay-45a73b68a0f9ebe58b42b12335e33c065b65821d.tar.bz2
gentoo-personal-overlay-45a73b68a0f9ebe58b42b12335e33c065b65821d.zip
sys-apps/shellrc: update to v0.5
Diffstat (limited to 'sys-apps/shellrc/shellrc-0.5-r1.ebuild')
-rw-r--r--sys-apps/shellrc/shellrc-0.5-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/shellrc/shellrc-0.5-r1.ebuild b/sys-apps/shellrc/shellrc-0.5-r1.ebuild
new file mode 100644
index 0000000..58915b7
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.5-r1.ebuild
@@ -0,0 +1,26 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop xorg +zsh +bash"
+
+DEPEND="zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( sys-fs/inotify-tools )
+ xorg? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=""
+ use bash && args="$args --bash" || true
+ use zsh && args="$args --zsh" || true
+ # TODO desktop and xorg
+
+ "${S}/install" --prefix "${D}" $args
+}