summaryrefslogtreecommitdiff
path: root/sys-apps/shellrc/shellrc-0.1-r2.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-01-26 15:45:26 +0100
committerKarel Kočí <cynerd@email.cz>2018-01-26 15:45:26 +0100
commitb9ea44e3cba5c45d782468beaecfd5373dfb5c05 (patch)
treef659a39baec05ae35f3f279cf1393175ad51bf5d /sys-apps/shellrc/shellrc-0.1-r2.ebuild
parent3507d03d3c990dc7714f94096dc13677ea71f2c0 (diff)
downloadgentoo-personal-overlay-b9ea44e3cba5c45d782468beaecfd5373dfb5c05.tar.gz
gentoo-personal-overlay-b9ea44e3cba5c45d782468beaecfd5373dfb5c05.tar.bz2
gentoo-personal-overlay-b9ea44e3cba5c45d782468beaecfd5373dfb5c05.zip
Move zshrc in shellrc package
Diffstat (limited to 'sys-apps/shellrc/shellrc-0.1-r2.ebuild')
-rw-r--r--sys-apps/shellrc/shellrc-0.1-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/shellrc/shellrc-0.1-r2.ebuild b/sys-apps/shellrc/shellrc-0.1-r2.ebuild
new file mode 100644
index 0000000..9f32ce6
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.1-r2.ebuild
@@ -0,0 +1,41 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop +zsh +bash"
+
+DEPEND="zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /etc
+ insinto /etc
+ doins -r "${S}/shellrc.d"
+
+ if use bash; then
+ dodir /etc/bash/bashrc.d
+ insinto /etc/bash
+ doins -r "${S}/bashrc.d"
+ dodir /usr/share/bash-completion/completions
+ insinto /usr/share/bash-completion/completions
+ doins -r "${S}"/bash-completion/*
+ fi
+
+ if use zsh; then
+ dodir /etc/zsh
+ insinto /etc/zsh
+ doins "${S}/zshrc"
+ doins -r "${S}/zshrc.d"
+ dodir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/site-functions
+ doins -r "${S}"/zsh-completion/*
+ fi
+}