summaryrefslogtreecommitdiff
path: root/sys-apps/shellrc/shellrc-0.1-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-01-26 15:34:21 +0100
committerKarel Kočí <cynerd@email.cz>2018-01-26 15:34:21 +0100
commitc68c2aab3ffc4ea9019b4ba64cf91b656ae02576 (patch)
treefca62a90d1f0cf1b251b324aedc251577dd9c9b2 /sys-apps/shellrc/shellrc-0.1-r1.ebuild
parentc2b812d383ce570a9fa410db2b89e5d1420173bd (diff)
downloadgentoo-personal-overlay-c68c2aab3ffc4ea9019b4ba64cf91b656ae02576.tar.gz
gentoo-personal-overlay-c68c2aab3ffc4ea9019b4ba64cf91b656ae02576.tar.bz2
gentoo-personal-overlay-c68c2aab3ffc4ea9019b4ba64cf91b656ae02576.zip
Add shellrc
Diffstat (limited to 'sys-apps/shellrc/shellrc-0.1-r1.ebuild')
-rw-r--r--sys-apps/shellrc/shellrc-0.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/shellrc/shellrc-0.1-r1.ebuild b/sys-apps/shellrc/shellrc-0.1-r1.ebuild
new file mode 100644
index 0000000..06d8970
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.1-r1.ebuild
@@ -0,0 +1,42 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop +zsh +bash"
+
+DEPEND="zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /etc
+ insinto /etc
+ doins -r "${S}/shellrc.d"
+
+ if use bash; then
+ dodir /etc/bash/bashrc.d
+ insinto /etc/bash
+ doins -r "${S}/bashrc.d"
+ dodir /usr/share/bash-completion/completions
+ insinto /usr/share/bash-completion/completions
+ doins -r "${S}"/bash-completion/*
+ fi
+
+ if use zsh; then
+ dodir /etc/zsh
+ insinto /etc
+ doins "${S}/zshrc"
+ insinto /etc/zsh
+ doins -r "${S}/zshrc.d"
+ dodir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/site-functions
+ doins -r "${S}"/zsh-completion/*
+ fi
+}