summaryrefslogtreecommitdiff
path: root/sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-01-26 15:35:23 +0100
committerKarel Kočí <cynerd@email.cz>2018-01-26 15:35:43 +0100
commit6a417adf33c288c67461373cc47050d5564f1fc9 (patch)
treed5cf606b21145eb76de1818b86288869340629b3 /sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild
parentc68c2aab3ffc4ea9019b4ba64cf91b656ae02576 (diff)
downloadgentoo-personal-overlay-6a417adf33c288c67461373cc47050d5564f1fc9.tar.gz
gentoo-personal-overlay-6a417adf33c288c67461373cc47050d5564f1fc9.tar.bz2
gentoo-personal-overlay-6a417adf33c288c67461373cc47050d5564f1fc9.zip
Small cleanup in multiconfig
Diffstat (limited to 'sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild')
-rw-r--r--sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild b/sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild
deleted file mode 100644
index 3f98840..0000000
--- a/sys-apps/multiconfig/multiconfig-0.1.2-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-EAPI=6
-
-VER="${PV%-r*}"
-
-DESCRIPTION="Multiple configuration system"
-HOMEPAGE="http://git.cynerd.cz/multiconfig/"
-SRC_URI="http://git.cynerd.cz/multiconfig/snapshot/multiconfig-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/multiconfig-${VER}"
-
-LICENSE="GPL-3.0+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="bridge firewall openvpn"
-
-DEPEND="bridge? ( net-misc/dhcp )
- firewall? ( net-firewall/iptables )
- openvpn? ( net-vpn/openvpn )
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- dodir /usr/sbin
- exeinto /usr/sbin
- doexe "${S}/multiconfig.sh"
- dodir /usr/lib/multiconfig
- touch "${D}"/usr/lib/multiconfig/.keep
- # TODO cron
-
- if use bridge; then
- doinitd "${S}/bridge/init/bridge"
- doinitd "${S}/bridge/init/bridge-dhcp"
-
- dodir /etc/dhcp
- insinto /etc/dhcp
- newins "${S}/bridge/dhcpd.conf" "bridge_dhcpd.conf"
-
- dodir /etc/sysctl.d
- insinto /etc/sysctl.d
- newins "${S}/bridge/sysctl.conf" "bridge.conf"
- fi
-
- if use firewall; then
- cp "${S}/firewall/multiconfig.sh" "${D}/usr/lib/multiconfig/firewall"
- fi
-
- if use openvpn; then
- cp "${S}/openvpn/multiconfig.sh" "${D}/usr/lib/multiconfig/openvpn"
- # TODO
- fi
-}
-
-pkg_postinst() {
- # TODO run multiconfig
- # TODO check if they are not activated
- use bridge && einfo "Don't forget to activate bridge and bridge-dhcp services"
- use firewall && einfo "Don't forget to activate iptables and ip6tables services"
- use openvpn && einfo "Don't forget to activate myvpn service"
-}