summaryrefslogtreecommitdiff
path: root/net-misc/vde/vde-2.3.2-r5.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-02-05 18:35:20 +0100
committerKarel Kočí <cynerd@email.cz>2018-02-05 18:35:20 +0100
commitc737fb227929d5b0d5f01d61464d965bd9d2b0fc (patch)
treea1c79f0f4eb4539c6316b9025f565da33909e296 /net-misc/vde/vde-2.3.2-r5.ebuild
parent5f30c47548e72fc9608ba3237c2cfba1647231d7 (diff)
downloadgentoo-personal-overlay-c737fb227929d5b0d5f01d61464d965bd9d2b0fc.tar.gz
gentoo-personal-overlay-c737fb227929d5b0d5f01d61464d965bd9d2b0fc.tar.bz2
gentoo-personal-overlay-c737fb227929d5b0d5f01d61464d965bd9d2b0fc.zip
Try to fix vde compilation
Diffstat (limited to 'net-misc/vde/vde-2.3.2-r5.ebuild')
-rw-r--r--net-misc/vde/vde-2.3.2-r5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/vde/vde-2.3.2-r5.ebuild b/net-misc/vde/vde-2.3.2-r5.ebuild
new file mode 100644
index 0000000..04e0397
--- /dev/null
+++ b/net-misc/vde/vde-2.3.2-r5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ltprune python-single-r1 user
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
+SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
+HOMEPAGE="http://vde.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86"
+IUSE="pcap python selinux ssl libressl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPS="pcap? ( net-libs/libpcap )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${COMMON_DEPS}"
+RDEPEND="${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-vde )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-format-security.patch",
+ "${FILESDIR}/${P}-openssl-1.1.0.patch"
+)
+
+pkg_setup() {
+ # default group already used in kqemu
+ enewgroup qemu
+
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable pcap) \
+ $(use_enable python) \
+ $(use_enable ssl cryptcab) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ newinitd "${FILESDIR}"/vde.init-r1 vde
+ newconfd "${FILESDIR}"/vde.conf-r1 vde
+}
+
+pkg_postinst() {
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+}