summaryrefslogtreecommitdiff
path: root/net-misc/vde/vde-2.3.2-r5.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-12 19:18:07 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-12 19:18:07 +0200
commita2111307ea7c50b0b77f0fb725bc9abc3aecbdd6 (patch)
tree4205ef16e3fcb03e1b03ce963ac403389791a203 /net-misc/vde/vde-2.3.2-r5.ebuild
parent6ab2ede60dd64987ba50a8a7163699c938595167 (diff)
downloadgentoo-personal-overlay-a2111307ea7c50b0b77f0fb725bc9abc3aecbdd6.tar.gz
gentoo-personal-overlay-a2111307ea7c50b0b77f0fb725bc9abc3aecbdd6.tar.bz2
gentoo-personal-overlay-a2111307ea7c50b0b77f0fb725bc9abc3aecbdd6.zip
Drop net-misc/vde
It is upstream package. But I seems to have done some hacking to it but I have not idea why. Probably openssl 1.1 support and it seems to me that I have not sent it to upstream. Let's see if I break something if I remove it.
Diffstat (limited to 'net-misc/vde/vde-2.3.2-r5.ebuild')
-rw-r--r--net-misc/vde/vde-2.3.2-r5.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/net-misc/vde/vde-2.3.2-r5.ebuild b/net-misc/vde/vde-2.3.2-r5.ebuild
deleted file mode 100644
index 565438e..0000000
--- a/net-misc/vde/vde-2.3.2-r5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit ltprune python-single-r1 user
-
-MY_P="${PN}2-${PV}"
-
-DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
-SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
-HOMEPAGE="http://vde.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86"
-IUSE="pcap python selinux ssl libressl static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPS="pcap? ( net-libs/libpcap )
- python? ( ${PYTHON_DEPS} )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${COMMON_DEPS}"
-RDEPEND="${COMMON_DEPS}
- selinux? ( sec-policy/selinux-vde )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-format-security.patch"
- "${FILESDIR}/${P}-openssl-1.1.0.patch"
-)
-
-pkg_setup() {
- # default group already used in kqemu
- enewgroup qemu
-
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- econf \
- $(use_enable pcap) \
- $(use_enable python) \
- $(use_enable ssl cryptcab) \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- default
- prune_libtool_files
-
- newinitd "${FILESDIR}"/vde.init-r1 vde
- newconfd "${FILESDIR}"/vde.conf-r1 vde
-}
-
-pkg_postinst() {
- einfo "To start vde automatically add it to the default runlevel:"
- einfo "# rc-update add vde default"
- einfo "You need to setup tap0 in /etc/conf.d/net"
- einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
-}