summaryrefslogtreecommitdiff
path: root/net-libs/libwpe/libwpe-1.4.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-09-29 14:48:01 +0200
committerKarel Kočí <cynerd@email.cz>2019-09-29 14:48:01 +0200
commitc11bd1e255716989c11adf1c3228ad72bb6d13fb (patch)
treef4ce804cdc11256652b3cff509e2603d715a0830 /net-libs/libwpe/libwpe-1.4.0.ebuild
parent30cefadcce87469c0cbb285c80d92dae420450fd (diff)
downloadgentoo-personal-overlay-c11bd1e255716989c11adf1c3228ad72bb6d13fb.tar.gz
gentoo-personal-overlay-c11bd1e255716989c11adf1c3228ad72bb6d13fb.tar.bz2
gentoo-personal-overlay-c11bd1e255716989c11adf1c3228ad72bb6d13fb.zip
net-libs/libwpe: Add new package
Diffstat (limited to 'net-libs/libwpe/libwpe-1.4.0.ebuild')
-rw-r--r--net-libs/libwpe/libwpe-1.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libwpe/libwpe-1.4.0.ebuild b/net-libs/libwpe/libwpe-1.4.0.ebuild
new file mode 100644
index 0000000..ae14e0c
--- /dev/null
+++ b/net-libs/libwpe/libwpe-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="General-purpose library for WPE WebKit"
+HOMEPAGE="https://www.wpewebkit.org"
+SRC_URI="https://www.wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}