summaryrefslogtreecommitdiff
path: root/net-im/ferdi/ferdi-5.6.3.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-11-18 09:25:13 +0100
committerKarel Kočí <cynerd@email.cz>2021-11-18 09:25:13 +0100
commit9f28a93373c801e41e70664f8e545c302d81f99f (patch)
tree59db5e91e5b43129f22001a0ee7437e1f0dfa4f9 /net-im/ferdi/ferdi-5.6.3.ebuild
parent67176d7906773f96bd6e6e09d6a00c4cbef6ac60 (diff)
downloadgentoo-personal-overlay-9f28a93373c801e41e70664f8e545c302d81f99f.tar.gz
gentoo-personal-overlay-9f28a93373c801e41e70664f8e545c302d81f99f.tar.bz2
gentoo-personal-overlay-9f28a93373c801e41e70664f8e545c302d81f99f.zip
net-im/ferdi: update to version 5.6.3
Diffstat (limited to 'net-im/ferdi/ferdi-5.6.3.ebuild')
-rw-r--r--net-im/ferdi/ferdi-5.6.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-im/ferdi/ferdi-5.6.3.ebuild b/net-im/ferdi/ferdi-5.6.3.ebuild
new file mode 100644
index 0000000..a3e30e7
--- /dev/null
+++ b/net-im/ferdi/ferdi-5.6.3.ebuild
@@ -0,0 +1,20 @@
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Messaging app that combines common web applications into one"
+HOMEPAGE="https://getferdi.com/"
+SRC_URI="https://github.com/getferdi/ferdi/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_install() {
+ dodir /opt
+ cp -R "${S}/${P}/" "${D}/opt/ferdi/" || die "Install failed!"
+ dodir /usr/bin
+ ln -s /opt/ferdi/ferdi "${D}/usr/bin/ferdi"
+ make_desktop_entry ferdi Ferdi
+}