summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-02-18 21:00:42 +0100
committerKarel Kočí <cynerd@email.cz>2018-02-18 21:00:42 +0100
commited4439a3051de1c072268054bc7ec1402d73df54 (patch)
tree1c190d2dab63e44c8d812f5c186c58f5e7d35f06 /mail-client
parent053a59b2b184728fe7820ea8a24d99fc513824b5 (diff)
downloadgentoo-personal-overlay-ed4439a3051de1c072268054bc7ec1402d73df54.tar.gz
gentoo-personal-overlay-ed4439a3051de1c072268054bc7ec1402d73df54.tar.bz2
gentoo-personal-overlay-ed4439a3051de1c072268054bc7ec1402d73df54.zip
Try to fix alot package
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.6.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
new file mode 100644
index 0000000..a0d34fd
--- /dev/null
+++ b/mail-client/alot/Manifest
@@ -0,0 +1 @@
+DIST alot-0.6.tar.gz 1527183 BLAKE2B 60e06d806bf5bfacdec485c3bcde6a5473bce2093abcc20d5e105b40f6d78bf93773c3b54311fdbbb632abe724a410d8941cfb0018842ee445ccea64c73a5033 SHA512 300b99d4919dd59d569de49195e33a3224bc28fbddf0b2aa6e3b419e030a22ec2d9acf389d67eb062cad9f2cd85f019cd6dff23e724491718e246397e70ed059
diff --git a/mail-client/alot/alot-0.6.ebuild b/mail-client/alot/alot-0.6.ebuild
new file mode 100644
index 0000000..02fec85
--- /dev/null
+++ b/mail-client/alot/alot-0.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ >=dev-python/twisted-10.2.0[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ "
+
+python_prepare_all() {
+ find "${S}" -name '*.py' -exec sed -e '1i# -*- coding: utf-8 -*-' -i '{}' +
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ echo
+ else
+ local rv
+ for rv in ${REPLACING_VERSIONS} ; do
+ if [[ "0.3.2" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ break;
+ fi
+ if [[ "0.5.1" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
+ ewarn "to use GPG signing operations, you can pass the key id has arg"
+ ewarn "or setup the gpg_key value in your config file, see"
+ ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
+ ewarn ""
+ break;
+ fi
+ done
+ fi
+}