summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-11-11 07:33:18 +0100
committerKarel Kočí <cynerd@email.cz>2021-11-11 07:33:18 +0100
commite6ed4bc418cbc82023a7750dd6aea7ab24cd90bd (patch)
tree80233da10b98ea3cd8004899e0e72bb3c0857baf /mail-client
parent0e0040c583b667fc37b5a2f7c07cfa0e983e2db1 (diff)
downloadgentoo-personal-overlay-e6ed4bc418cbc82023a7750dd6aea7ab24cd90bd.tar.gz
gentoo-personal-overlay-e6ed4bc418cbc82023a7750dd6aea7ab24cd90bd.tar.bz2
gentoo-personal-overlay-e6ed4bc418cbc82023a7750dd6aea7ab24cd90bd.zip
mail-clinet/astroid: update to version 0.16
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/astroid/Manifest2
-rw-r--r--mail-client/astroid/astroid-0.16-r1.ebuild (renamed from mail-client/astroid/astroid-0.15-r1.ebuild)4
-rw-r--r--mail-client/astroid/files/astroid-0.15-use-std-placeholders-everywhere.patch160
3 files changed, 1 insertions, 165 deletions
diff --git a/mail-client/astroid/Manifest b/mail-client/astroid/Manifest
index 7457748..dc6d0e1 100644
--- a/mail-client/astroid/Manifest
+++ b/mail-client/astroid/Manifest
@@ -1 +1 @@
-DIST v0.15.tar.gz 3365732 BLAKE2B f06297c0a4c1c4dae6b5d5c77be76d0547ffb8a47e0dda0402df75f623266485e88565958a8302faf00201b2c2929ffadcb247ca572d7867267bbb9a9551c69a SHA512 e8bb8d7b32d5f443615d21ce639e59bf93b11e790d8a6ef7d63919c36aba2bcf3841b3f3a36cc34e15bc668bee47e0b525271f8f7b8dc38071a8e3bed19fce0d
+DIST v0.16.tar.gz 3370206 BLAKE2B c23d47655cfac51240da15723bb249b8fb678e4fafde8acd706ca22ce9d2a9f91fd7a645edc236e5af6155f5853c8a0dc35ed50af4f378ba149760d5a1556f44 SHA512 af7072e2842b9b81d1e48eb89ab4f40e6853a280a7afed88cd38e71e4cb78a8a7a0b380291080e2bddc94e077a0793bb9886b3b5249396206c3fc0b77df81707
diff --git a/mail-client/astroid/astroid-0.15-r1.ebuild b/mail-client/astroid/astroid-0.16-r1.ebuild
index c82bed7..d26c184 100644
--- a/mail-client/astroid/astroid-0.15-r1.ebuild
+++ b/mail-client/astroid/astroid-0.16-r1.ebuild
@@ -21,7 +21,3 @@ RDEPEND="
net-libs/libsoup
net-mail/notmuch
"
-
-PATCHES=(
- "${FILESDIR}/${P}-use-std-placeholders-everywhere.patch"
-)
diff --git a/mail-client/astroid/files/astroid-0.15-use-std-placeholders-everywhere.patch b/mail-client/astroid/files/astroid-0.15-use-std-placeholders-everywhere.patch
deleted file mode 100644
index 465b877..0000000
--- a/mail-client/astroid/files/astroid-0.15-use-std-placeholders-everywhere.patch
+++ /dev/null
@@ -1,160 +0,0 @@
-From 0723bf78587eb9c36fa304e33e53b0dfae112589 Mon Sep 17 00:00:00 2001
-From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
-Date: Tue, 15 Sep 2020 20:27:59 -0400
-Subject: [PATCH] use std::placeholders everywhere
-
-before this was silently relying on boost placeholders, but those
-default off now.
----
- src/config.cc | 2 +-
- src/main_window.cc | 20 +++++++++----------
- src/modes/keybindings.cc | 2 +-
- .../thread_index/thread_index_list_view.cc | 14 ++++++-------
- 4 files changed, 19 insertions(+), 19 deletions(-)
-
-diff --git a/src/config.cc b/src/config.cc
-index bb967b4..5d62ee5 100644
---- a/src/config.cc
-+++ b/src/config.cc
-@@ -488,7 +488,7 @@ namespace Astroid {
- void Config::merge_ptree(const ptree &pt) {
- function<void(const ptree &,
- const ptree::path_type &,
-- const ptree&)> method = bind (&Config::merge, this, _1, _2, _3);
-+ const ptree&)> method = bind (&Config::merge, this, std::placeholders::_1, std::placeholders::_2, std::placeholders::_3);
-
- traverse(pt, method);
- }
-diff --git a/src/main_window.cc b/src/main_window.cc
-index 7b5b826..2b885c7 100644
---- a/src/main_window.cc
-+++ b/src/main_window.cc
-@@ -260,52 +260,52 @@ namespace Astroid {
- keys.register_key ("M-1",
- "main_window.jump_to_page_1",
- "Jump to page 1",
-- bind (&MainWindow::jump_to_page, this, _1, 1));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 1));
-
- keys.register_key ("M-2",
- "main_window.jump_to_page_2",
- "Jump to page 2",
-- bind (&MainWindow::jump_to_page, this, _1, 2));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 2));
-
- keys.register_key ("M-3",
- "main_window.jump_to_page_3",
- "Jump to page 3",
-- bind (&MainWindow::jump_to_page, this, _1, 3));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 3));
-
- keys.register_key ("M-4",
- "main_window.jump_to_page_4",
- "Jump to page 4",
-- bind (&MainWindow::jump_to_page, this, _1, 4));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 4));
-
- keys.register_key ("M-5",
- "main_window.jump_to_page_5",
- "Jump to page 5",
-- bind (&MainWindow::jump_to_page, this, _1, 5));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 5));
-
- keys.register_key ("M-6",
- "main_window.jump_to_page_6",
- "Jump to page 6",
-- bind (&MainWindow::jump_to_page, this, _1, 6));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 6));
-
- keys.register_key ("M-7",
- "main_window.jump_to_page_7",
- "Jump to page 7",
-- bind (&MainWindow::jump_to_page, this, _1, 7));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 7));
-
- keys.register_key ("M-8",
- "main_window.jump_to_page_8",
- "Jump to page 8",
-- bind (&MainWindow::jump_to_page, this, _1, 8));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 8));
-
- keys.register_key ("M-9",
- "main_window.jump_to_page_9",
- "Jump to page 9",
-- bind (&MainWindow::jump_to_page, this, _1, 9));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 9));
-
- keys.register_key ("M-0",
- "main_window.jump_to_page_0",
- "Jump to page 0",
-- bind (&MainWindow::jump_to_page, this, _1, 0));
-+ bind (&MainWindow::jump_to_page, this, std::placeholders::_1, 0));
-
- keys.register_key ("C-w", "main_window.close_page",
- "Close mode (or window if other windows are open)",
-diff --git a/src/modes/keybindings.cc b/src/modes/keybindings.cc
-index 65e8cd8..08f1e40 100644
---- a/src/modes/keybindings.cc
-+++ b/src/modes/keybindings.cc
-@@ -561,7 +561,7 @@ namespace Astroid {
- register_key (b->first,
- b->first.name,
- ustring::compose ("Run hook: %1,%2", b->second.first, b->second.second),
-- bind (cb, _1, b->second.first, b->second.second)
-+ bind (cb, std::placeholders::_1, b->second.first, b->second.second)
- );
-
- b++;
-diff --git a/src/modes/thread_index/thread_index_list_view.cc b/src/modes/thread_index/thread_index_list_view.cc
-index d716db1..b32c378 100644
---- a/src/modes/thread_index/thread_index_list_view.cc
-+++ b/src/modes/thread_index/thread_index_list_view.cc
-@@ -477,38 +477,38 @@ namespace Astroid {
- multi_keys.register_key ("N",
- "thread_index.multi.mark_unread",
- "Toggle unread",
-- bind (&ThreadIndexListView::multi_key_handler, this, MUnread, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MUnread, std::placeholders::_1));
-
- multi_keys.register_key ("*",
- "thread_index.multi.flag",
- "Toggle flagged",
-- bind (&ThreadIndexListView::multi_key_handler, this, MFlag, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MFlag, std::placeholders::_1));
-
- multi_keys.register_key ("a",
- "thread_index.multi.archive",
- "Toggle archive",
-- bind (&ThreadIndexListView::multi_key_handler, this, MArchive, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MArchive, std::placeholders::_1));
-
- multi_keys.register_key ("S",
- "thread_index.multi.mark_spam",
- "Toggle spam",
-- bind (&ThreadIndexListView::multi_key_handler, this, MSpam, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MSpam, std::placeholders::_1));
-
- multi_keys.register_key ("+",
- "thread_index.multi.tag",
- "Tag",
-- bind (&ThreadIndexListView::multi_key_handler, this, MTag, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MTag, std::placeholders::_1));
-
-
- multi_keys.register_key ("C-m",
- "thread_index.multi.mute",
- "Toggle mute",
-- bind (&ThreadIndexListView::multi_key_handler, this, MMute, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MMute, std::placeholders::_1));
-
- multi_keys.register_key ("t",
- "thread_index.multi.toggle",
- "Toggle marked",
-- bind (&ThreadIndexListView::multi_key_handler, this, MToggle, _1));
-+ bind (&ThreadIndexListView::multi_key_handler, this, MToggle, std::placeholders::_1));
-
- keys->register_key (Key (GDK_KEY_semicolon),
- "thread_index.multi",
---
-2.29.2
-