summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-05-27 09:29:14 +0200
committerKarel Kočí <cynerd@email.cz>2021-05-27 09:29:14 +0200
commit6e662fd93b5f9dbfdcb833444e4035fc26a00b96 (patch)
tree1f473cf12b9635aa20e58ece920cacd45712ac00 /dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
parent5ad399199a30f4b0ed9b42ac16e7ff2a38d3e263 (diff)
downloadgentoo-personal-overlay-6e662fd93b5f9dbfdcb833444e4035fc26a00b96.tar.gz
gentoo-personal-overlay-6e662fd93b5f9dbfdcb833444e4035fc26a00b96.tar.bz2
gentoo-personal-overlay-6e662fd93b5f9dbfdcb833444e4035fc26a00b96.zip
dev-vcs/python-gitlab: update to latest version
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
new file mode 100644
index 0000000..615fc53
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}